As a CCNA instructor, I'll guide you through configuring a point-to-multipoint (P2MP) OSPF network in this Metro Ethernet WAN scenario. This topology shows a hub-and-spoke design with Tehran HQ-Router as the hub and three branch routers as spokes.
Understanding the Topology
From the image, we can see:
OSPF Area 0 is the backbone area
HQ-Router is the hub with three subinterfaces (VLANs 10, 20, 30)
Three branch routers (Shiraz, Mashhad, Tabriz) connect to the hub via Metro Ethernet
The ISP provides the Metro Ethernet service
Point-to-Multipoint Network Characteristics
P2MP is ideal for this scenario because:
It's a hub-and-spoke topology
All spokes connect to a single hub interface (logically)
We want to treat the WAN like a multi-access network
It avoids the need for full mesh connectivity
Configuration Steps
Copy HQ-Router#configure terminal
HQ-Router(config)#interface fastEthernet 0/0
HQ-Router(config-if)#no shutdown et0/0, changed state to up
HQ-Router(config-if)#exit
HQ-Router(config)#interface fastEthernet 0/0.1
HQ-Router(config-subif)#encapsulation dot1Q 10
HQ-Router(config-subif)#ip address 192.168.10.1 255.255.255.0
HQ-Router(config-subif)#ip ospf network point-to-multipoint
HQ-Router(config-subif)#exit
HQ-Router(config)#interface fastEthernet 0/0.2
HQ-Router(config-subif)#encapsulation dot1Q 20
HQ-Router(config-subif)#ip address 192.168.20.1 255.255.255.0
HQ-Router(config-subif)#ip ospf network point-to-multipoint
HQ-Router(config-subif)#exit
HQ-Router(config)#interface fastEthernet 0/0.3
HQ-Router(config-subif)#encapsulation dot1Q 30
HQ-Router(config-subif)#ip address 192.168.30.1 255.255.255.0
HQ-Router(config-subif)#ip ospf network point-to-multipoint
HQ-Router(config-subif)#exit
HQ-Router(config)#router ospf 1
HQ-Router(config-router)#net
HQ-Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
HQ-Router(config-router)#network 192.168.20.0 0.0.0.255 area 0
HQ-Router(config-router)#network 192.168.30.0 0.0.0.255 area 0
HQ-Router(config-router)#^Z
HQ-Router#write memory
Copy Branch-1#configure terminal
Branch-1(config)#interface fastEthernet 0/0
Branch-1(config-if)#ip address 192.168.10.2 255.255.255.0
Branch-1(config-if)#ip ospf network point-to-multipoint
Branch-1(config-if)#no shutdown
Branch-1(config-if)#exit
Branch-1(config)#router ospf 1
Branch-1(config-router)#network 192.168.10.0 0.0.0.255 area 0
Branch-1(config-router)#^Z
Branch-1#write memory
Copy Branch-2#configure terminal
Branch-2(config)#interface fastEthernet 0/0
Branch-2(config-if)#ip address 192.168.20.2 255.255.255.0
Branch-2(config-if)#ip ospf network point-to-multipoint
Branch-2(config-if)#no shutdown
Branch-2(config-if)#exit
Branch-2(config)#router ospf 1
Branch-2(config-router)#network 192.168.20.0 0.0.0.255 area 0
Branch-2(config-router)#^Z
Branch-2#write memory
Copy Branch-3#configure terminal
Branch-3(config)#interface fastEthernet 0/0
Branch-3(config-if)#ip address 192.168.30.2 255.255.255.0
Branch-3(config-if)#ip ospf network point-to-multipoint
Branch-3(config-if)#no shutdown
Branch-3(config-if)#exit
Branch-3(config)#router ospf 1
Branch-3(config-router)#network 192.168.30.0 0.0.0.255 area 0
Branch-3(config-router)#^Z
Branch-3#write memory
5. ISP Configuration (Metro Ethernet Switch)
Copy ISP#configure terminal
ISP(config)#vlan 10
ISP(config-vlan)#name BRANCH-1
ISP(config-vlan)#exit
ISP(config)#vlan 20
ISP(config-vlan)#name BRANCH-2
ISP(config-vlan)#exit
ISP(config)#vlan 30
ISP(config-vlan)#name BRANCH-3
ISP(config-vlan)#exit
ISP(config)#interface ethernet 0/0
ISP(config-if)#desc
ISP(config-if)#description TRUNK-TO-HQ-ROUTER
ISP(config-if)#switchport trunk encapsulation dot1q
ISP(config-if)#switchport mode trunk
ISP(config-if)#exit
ISP(config)#interface ethernet 0/1
ISP(config-if)#description BRANCH-1
ISP(config-if)#switchport mode access
ISP(config-if)#switchport access vlan 10
ISP(config-if)#exit
ISP(config)#interface ethernet 0/2
ISP(config-if)#description BRANCH-2
ISP(config-if)#switchport mode access
ISP(config-if)#switchport access vlan 20
ISP(config-if)#exit
ISP(config)#interface ethernet 0/3
ISP(config-if)#description BRANCH-3
ISP(config-if)#switchport mode access
ISP(config-if)#switchport access vlan 30
ISP(config-if)#^Z
ISP#write memory
Verify IP Connectivity (ping between devices)
Copy HQ-Router#ping 192.168.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/28 ms
HQ-Router#ping 192.168.20.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/28 ms
HQ-Router#ping 192.168.30.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/24 ms
HQ-Router#
Copy Branch-1#ping 192.168.20.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/27/36 ms
Branch-1#ping 192.168.30.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/28 ms
Branch-1#
Copy Branch-2#ping 192.168.30.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/40 ms
Branch-2#
Keywords
OSPF
, Point-to-Multipoint
, Metro Ethernet
, Hub-and-Spoke
, NBMA
, DR/BDR
, Subinterfaces
, Cisco Configuration
, Routing Protocol
, WAN
, VLAN
, OSPF Neighbors
, Multicast
, Non-Broadcast
, Hello Timers
, IP Subnetting
, Network Design
, Scalability
, Troubleshooting
, Best Practices
, سیسکو